Skip to main content
Asked a question 3 years ago

Every time I try to insert an image into my broadcast, nothing happens. That block/section just stays empty. I've uploaded an image a couple of different times, tried changing the file name and reuploading, tried closing the tab/page and starting all over again, etc. I'm using the "new editor" today for the first time because it's supposed to be better than the legacy editor (which is also, frankly, super frustrating to use.) I've tried a dozen times now and no matter what I do, I cannot get the image to load. I have loaded other images successfully.

💡Make the most of your Community Member profile 

Share more about yourself! Click on your gravatar> profile > edit profile 

  • About You tab:
    • Photo: upload a picture of yourself or your brand
    • About You: let other community members know a little about you as a person, a creator, and anything else you'd like to add
    • Banner: add an image of your creator brand, logo, or an image that inspires your creativity
  • Social Media tab:
    • Let other members know where they can find you and your brand across social media platforms. This is a great additional step to connect with other creators in the industry!

Hey @Jacquelynne38, so sorry for the trouble! Could you please try again from a private browsing/Incognito window? If it works there, that might indicate that there's something in your cache or cookies that is interfering with ConvertKit on the regular browser window.

​You should be able to open a private browsing window by clicking File > New Incognito/Private Window and then navigate to ConvertKit from the window that opens. 

If the issue persists, though, please reach out to our team at help@convertkit.com26 (or via the in-app messenger in your account) with a description of the issue, the name of the broadcast you're trying to upload it to, and attach the image in question directly to your message. One of our Product Specialists will be able to help troubleshoot further! 

Thank you! :)