Skip to main content
sara
Naptimepreneur
Asked a question last year

Hello! I am new and just created my landing page and edited the email content to include a freebie. I used a landing page template and have edited it, including changing the page name in the left upper corner of the editor, however, when I share the link via message, the link still displays as the template name instead of my landing page/brand name. How do I fix it? I don't want people to get a "colossal musician" landing page link name to confuse people about who they are getting the link from. Everything else works well except this one detail. Much appreciate the help! Thank you

💡Make the most of your Community Member profile 

Share more about yourself! Click on your gravatar> profile > edit profile 

  • About You tab:
    • Photo: upload a picture of yourself or your brand
    • About You: let other community members know a little about you as a person, a creator, and anything else you'd like to add
    • Banner: add an image of your creator brand, logo, or an image that inspires your creativity
  • Social Media tab:
    • Let other members know where they can find you and your brand across social media platforms. This is a great additional step to connect with other creators in the industry!
Sarah Spencer
Songwriter / Designer

 

Hi Sara!

I hope I'm understanding your question correctly—I'm gonna take a guess that you may want to try these two things!

Edit the name of your Landing Page:

Check out the name of the Landing page in the top left corner of the editor screen:

Hello! I am new and just created my landing page and edited the email content to include a freebie. I used a landing page template and have edited it, including changing the page name in the left upper corner of the editor, however, when I share the link via message, the link still displays as the template name instead of my landing page/brand name. How do I fix it? I don't want people to get a "colossal musician" landing page link name to confuse people about who they are getting the link from. Everything else works well except this one detail. Much appreciate the help! Thank you

See the little pencil? Click there, and you can re-name your form however you like. This will change the name of the Landing Page internally, and also adjust what displays in the page title tag, or tab of the browser.

Hello! I am new and just created my landing page and edited the email content to include a freebie. I used a landing page template and have edited it, including changing the page name in the left upper corner of the editor, however, when I share the link via message, the link still displays as the template name instead of my landing page/brand name. How do I fix it? I don't want people to get a "colossal musician" landing page link name to confuse people about who they are getting the link from. Everything else works well except this one detail. Much appreciate the help! Thank you

If this isn't what you're asking, you can also try this:

Account Settings > Domain

This will adjust how the URL reads for your landing page.

Click your Avatar, and go into Account settings:

Hello! I am new and just created my landing page and edited the email content to include a freebie. I used a landing page template and have edited it, including changing the page name in the left upper corner of the editor, however, when I share the link via message, the link still displays as the template name instead of my landing page/brand name. How do I fix it? I don't want people to get a "colossal musician" landing page link name to confuse people about who they are getting the link from. Everything else works well except this one detail. Much appreciate the help! Thank you

This opens up the Account Info settings. See where it says Account Domain? You can add in your preferred URL in this space. (I've got mine set to sarahsheppardstudio)

Hello! I am new and just created my landing page and edited the email content to include a freebie. I used a landing page template and have edited it, including changing the page name in the left upper corner of the editor, however, when I share the link via message, the link still displays as the template name instead of my landing page/brand name. How do I fix it? I don't want people to get a "colossal musician" landing page link name to confuse people about who they are getting the link from. Everything else works well except this one detail. Much appreciate the help! Thank you

Now, any landing pages will be updated to use this url. :)

For example, here's one I've made just as a sample: https://sarahsheppardstudio.ck.page/75b3f35d5435

If you don't want the .ck.page25 part of the URL, you can Go into Account Settings > Custom Domains and link your CK account to your domain. I won't go into it here, definitely worth a look at the ConvertKit documentation :)

Hope this helps!! 🤍