Skip to main content
Asked a question 2 years ago

Hello, I just signed up to ConvertKit and I've been testing it but the landing page doesn't seem to work. I get the success message but I the email is never added as a subscriber and I'm not getting the autoresponse email. I setup a custom domain for the landing page. Any idea how to fix this?

💡Make the most of your Community Member profile 

Share more about yourself! Click on your gravatar> profile > edit profile 

  • About You tab:
    • Photo: upload a picture of yourself or your brand
    • About You: let other community members know a little about you as a person, a creator, and anything else you'd like to add
    • Banner: add an image of your creator brand, logo, or an image that inspires your creativity
  • Social Media tab:
    • Let other members know where they can find you and your brand across social media platforms. This is a great additional step to connect with other creators in the industry!

Hey @Hector Sanchez45! Sorry for the trouble. If you're not receiving the incentive email, we have a troubleshooting guide on that here49. Also, please note that if you have double opt-in39 enabled on that landing page, subscribers will show up on your list as unconfirmed until they click the link in the incentive email (more info on that in this answer42).

If the issue persists after those troubleshooting steps, though, please feel free to reach out to our team at help@convertkit.com41 (or via the in-app messenger in your account) with a description of this issue, the email address(s) of example subscribers experiencing it, and the name of the landing page (as it is displayed on the forms page43 in your account). One of our Product Specialists will be able to help troubleshoot further! :)

Question Stats

259 view
1 follower
Asked a question 2 years ago
Views this month