Skip to main content
Question
Asked a question 2 years ago

Hi, I have the ConvertKit plugin installed on my website and set on default to load a modal form after visitors have been on the site for 5 seconds. It seems to be working for all of the pages except for the homepage. I've tried in both Google Chrome and Safari browsers - incognito/private mode as well. Is there something special I need to do to the homepage to get the modal to trigger? http://elizabethcunninghamwrites.com/

💡Make the most of your Community Member profile 

Share more about yourself! Click on your gravatar> profile > edit profile 

  • About You tab:
    • Photo: upload a picture of yourself or your brand
    • About You: let other community members know a little about you as a person, a creator, and anything else you'd like to add
    • Banner: add an image of your creator brand, logo, or an image that inspires your creativity
  • Social Media tab:
    • Let other members know where they can find you and your brand across social media platforms. This is a great additional step to connect with other creators in the industry!

Hey @Elizabeth Cunningham21! It looks like your homepage may be the 'Recent posts' page in WordPress. The form set as your default in the plugin won't load on that page, but you should be able to add it as a widget in the sidebar instead, or something else that loads on each page (like the footer). If you go that route, you'll probably need to remove the modal as your default (and just leave it in the widget instead), otherwise it might show up twice on the pages that support both method of adding the form.