Skip to main content
Question
Asked a question 2 years ago

I created a landing page yesterday. I've just gone in to edit it but when I click on edit, I get a blank page. I have cleared cookies, emptied cache etc but no joy. Is the system down? I've tried to create a new one and cannot do so either.

💡Make the most of your Community Member profile 

Share more about yourself! Click on your gravatar> profile > edit profile 

  • About You tab:
    • Photo: upload a picture of yourself or your brand
    • About You: let other community members know a little about you as a person, a creator, and anything else you'd like to add
    • Banner: add an image of your creator brand, logo, or an image that inspires your creativity
  • Social Media tab:
    • Let other members know where they can find you and your brand across social media platforms. This is a great additional step to connect with other creators in the industry!

Same thing happening to me. I wish there was live support somewhere (maybe there is, I just can't find it)

Hey @enquiries@thesmartkid.info28 & @Gerard Groarke29! Sorry for the trouble.

Please note that the backend of our app isn't fully tested or supported on Internet Explorer and Edge, so there may be some display issues like what you describe on those browsers. (I'm not sure if you might be using one of those, but if so, we would recommend using Chrome, Firefox, or Safari instead.)

If the issue is occurring on a supported browser, we would recommend trying again from a private browsing/Incognito window. If it works there, that might indicate that there's something in your cache or cookies that is interfering with ConvertKit on the regular browser window.

If the issue still persists after that, please reach out to our team via help@convertkit.com27 (or via the in-app messenger in your account) with a description of the issue and which troubleshooting steps you've already attempted (screenshots are helpful, too!). Thank you! :)