Skip to main content
Question
forms
Lee Beaser
Founder, The Career Counter
Asked a question 2 years ago

I'm having trouble adding a modal form triggered with a button click. I am embedding the javascript in the page header. I have the trigger link in the button code. When I click the button, the form pops up for an instant, then quicly goes to a new page where the form is the only thing displayed. I tried using the wordpress plugin instead of the javascript to no effect. Any thoughts to prevent this and keep the modal form on the original page?

πŸ’‘Make the most of your Community Member profileΒ 

Share more about yourself! Click on your gravatar> profile > edit profileΒ 

  • About You tab:
    • Photo: upload a picture of yourself or your brand
    • About You: let other community members know a little about you as a person, a creator, and anything else you'd like to add
    • Banner: add an image of your creator brand, logo, or an image that inspires your creativity
  • Social Media tab:
    • Let other members know where they can find you and your brand across social media platforms. This is a great additional step to connect with other creators in the industry!

Hi @Lee Beaser45 ! It sounds like maybe the form is set up as an embed and then again as a trigger in the button. If you scroll to the end of this article81 , it explains how to link your form with a button:

I'm having trouble adding a modal form triggered with a button click. I am embedding the javascript in the page header. I have the trigger link in the button code. When I click the button, the form pops up for an instant, then quicly goes to a new page where the form is the only thing displayed. I tried using the wordpress plugin instead of the javascript to no effect.  Any thoughts to prevent this and keep the modal form on the original page?

When you click the link the modal should appear.

NOTE: If you only want the modal to appear based on the click you can set the timing really high (9999 seconds) or set the scroll percentage to 100%.

Can you try that to see if that helps? :)