Skip to main content
Question
Quick Tips
Asked a question 2 months ago

I made a landing page to gather emails. Very pleased! When I enter a test name and email, the 'successfully subscribed' message pops up. But no email goes to the test email, and there's no record on this site of a new subscriber. I'm sure I'm missing something simple ... (I'm using double opt-in. Should I turn that off?) ETA: The test email is in 'Unconfirmed Subscribers' but ... it's not confirmed because it was never delivered to the address! Not in spam folder, either. Gah!

💡Make the most of your Community Member profile 

Share more about yourself! Click on your gravatar> profile > edit profile 

  • About You tab:
    • Photo: upload a picture of yourself or your brand
    • About You: let other community members know a little about you as a person, a creator, and anything else you'd like to add
    • Banner: add an image of your creator brand, logo, or an image that inspires your creativity
  • Social Media tab:
    • Let other members know where they can find you and your brand across social media platforms. This is a great additional step to connect with other creators in the industry!
Robert
Free Diver | Adventurer

Hey Ian -- There's actually a lot that might have happened here. It can be that you are using a free domain(google.com14 or yahoo.com11) as it has a tendency for the email to not arrive or land in the spam folder. or the subscriber has a strict domain setting that prevents their inbox provider to receive emails from you. You can either reach out to your subscribers outside CK and request to allowlist your sending email address, or you might need to reach out to ConvertKit support so that they can check out what happened. You can reach their support here: https://convertkit.com/support14