Skip to main content
Asked a question last year

The landing page I created doesn't seem to be sending confirmation emails once someone subscribes. I've tested it by sending emails to me without success. The link is bit.ly/TWTEmailList0421. When I type that directly, I can get to the landing page, fill out the information, and then nothing. No email is received. There is an incentive to sign up as well. I've included it in the settings and added it as a download. I've tried several email addresses that I have. Can someone help me with this? Thanks.

💡Make the most of your Community Member profile 

Share more about yourself! Click on your gravatar> profile > edit profile 

  • About You tab:
    • Photo: upload a picture of yourself or your brand
    • About You: let other community members know a little about you as a person, a creator, and anything else you'd like to add
    • Banner: add an image of your creator brand, logo, or an image that inspires your creativity
  • Social Media tab:
    • Let other members know where they can find you and your brand across social media platforms. This is a great additional step to connect with other creators in the industry!
Tanisha
ConvertKit Rockstar

1. Setup a sequence with the confirmation email
2. Go to Automation, then to RULES 
3. ADD a new Rule
4. When a Form is completed/subscribed -- LEFT SIDE
5. This should Trigger the Confirmation sequence, you have made in Point 1
6. This will solve your issue. 

Question Stats

332 view
1 follower
Asked a question last year
Views this month