Skip to main content
Asked a question 7 months ago

When accessing my custom domain, I get the following error: "sni-support-required-for-valid-ssl", which indicates, there is something not configured correctly on ConvertKits site. I could double-check DNS settings, configured via Cloudflare. What should I do? Thanks for your help.

💡Make the most of your Community Member profile 

Share more about yourself! Click on your gravatar> profile > edit profile 

  • About You tab:
    • Photo: upload a picture of yourself or your brand
    • About You: let other community members know a little about you as a person, a creator, and anything else you'd like to add
    • Banner: add an image of your creator brand, logo, or an image that inspires your creativity
  • Social Media tab:
    • Let other members know where they can find you and your brand across social media platforms. This is a great additional step to connect with other creators in the industry!
Kristine
ConvertKit Community Specialists

Hey @Dirk38 , sure! What domain name are you trying to assign to your landing page? By the way, you can also check this article - How to use a custom domain for landing pages35 or ask for assistance from our support team at https://convertkit.com/support17 so they can delve deeper into this domain issue. 

In Cloudflare, under SSL/TLS → Overview, try setting your encryption mode to Full.

If your landing page starts working, but you own other subdomains that support Full Strict, you will instead want to set up a Cloudflare Configuration Rule specifically targeting your ConvertKit landing page. This is the preferred option, as it will allow you to downgrade the security of your landing page only, rather than your entire site’s.

Another option is to disable Cloudflare for the ConvertKit landing page. Under DNS, change all three of your landing page’s A records from Proxied (orange cloud) to DNS Only (gray cloud) . This should only be a last resort if nothing else works.